libressl-CMS_ContentInfo_new(3)

libressl-CMS_ContentInfo_new3

Cryptographic message syntax data structures

Usage

Crypto Library (libcrypto, -lcrypto)

#include <openssl/cms.h>

CMS_ContentInfo *

CMS_ContentInfo_new(void);

void

CMS_ContentInfo_free(CMS_ContentInfo *cms);

int

CMS_ContentInfo_print_ctx(BIO *out, CMS_ContentInfo *cms, int indent, const ASN1_PCTX *pctx);

CMS_ReceiptRequest *

CMS_ReceiptRequest_new(void);

void

CMS_ReceiptRequest_free(CMS_ReceiptRequest *rr);

Overview

CMS_ContentInfo_new() allocates and initializes an empty CMS_ContentInfo object, representing an ASN.1 ContentInfo structure defined in RFC 5652 section 3. It can hold a pointer to an ASN.1 OBJECT IDENTIFIER and a pointer to either a SignedData, EnvelopedData, DigestedData, EncryptedData, AuthenticatedData, or CompressedData object or to an arbitrary ASN.1 object. CMS_ContentInfo_free() frees cms.

CMS_ContentInfo_print_ctx() prints a human readable representation of cms to out.

CMS_ReceiptRequest_new() allocates and initializes an empty CMS_ReceiptRequest object, representing an ASN.1 ReceiptRequest structure defined in RFC 2634 section 2.7. It can contain a content identifier, a list of recipients requested to return a signed receipt, and a list of users to send the receipt to. CMS_ReceiptRequest_free() frees rr.

Return values

CMS_ContentInfo_new() and CMS_ReceiptRequest_new() return the new CMS_ContentInfo or CMS_ReceiptRequest object, respectively, or NULL if an error occurs.

Standards

RFC 5652: Cryptographic Message Syntax, section 3: General Syntax

RFC 3274: Compressed Data Content Type for Cryptographic Message Syntax (CMS)

RFC 2634: Enhanced Security Services for S/MIME, section 2.7: Receipt Request Syntax

History

CMS_ContentInfo_new(), CMS_ContentInfo_free(), CMS_ReceiptRequest_new(), and CMS_ReceiptRequest_free() first appeared in OpenSSL 0.9.8h and CMS_ContentInfo_print_ctx() in OpenSSL 1.0.0. This function has been available since OpenBSD 6.7.

From libressl 4.4.0-1 in Arch Linux 2026-11-01. Parsed by carta from the page's mdoc source.