ldns_algorithm(3)

ldns_algorithm3

Numbers assigned to algorithms used in dns

Usage

#include <stdint.h>
#include <stdbool.h>

#include <ldns/ldns.h>

Overview

ldns_algorithm
Algorithms used in dns
enum ldns_enum_algorithm
{

LDNS_RSAMD5 = 1, /* RFC 4034,4035 */

LDNS_DH = 2,

LDNS_DSA = 3,

LDNS_ECC = 4,

LDNS_RSASHA1 = 5,

LDNS_DSA_NSEC3 = 6,

LDNS_RSASHA1_NSEC3 = 7,

LDNS_RSASHA256 = 8, /* RFC 5702 */

LDNS_RSASHA512 = 10, /* RFC 5702 */

LDNS_ECC_GOST = 12, /* RFC 5933 */

LDNS_ECDSAP256SHA256 = 13, /* RFC 6605 */

LDNS_ECDSAP384SHA384 = 14, /* RFC 6605 */

LDNS_ED25519 = 15, /* RFC 8080 */

LDNS_ED448 = 16, /* RFC 8080 */

LDNS_INDIRECT = 252,

LDNS_PRIVATEDNS = 253,

LDNS_PRIVATEOID = 254
};
typedef enum ldns_enum_algorithm ldns_algorithm;

Remarks

This manpage was automatically generated from the ldns source code.

Releases

6 releases since Debian 9 (Stretch); the text changed 3 times.

  1. 9–10
  2. 11
  3. 12
  4. 13–Arch

Author

The ldns team at NLnet Labs.

Reporting bugs

Please report bugs to [email protected] or on GitHub at https://github.com/NLnetLabs/ldns/issues

From ldns 1.9.2-1 in Arch Linux 2026-11-01. Parsed by carta from the page's man source.