Net::LDAP::RFC(3pm)

Net::LDAP::RFC3pm

List of related rfcs

Usage

  none

Overview

The LDAP protocol is defined in the following RFCs

Core LDAP Specification

RFC-4510 Lightweight Directory Access Protocol (LDAP): Technical Specification Road Map

http://www.ietf.org/rfc/rfc4510.txt

The Lightweight Directory Access Protocol (LDAP) is an Internet protocol for accessing distributed directory services that act in accordance with X.500 data and service models. This document provides a road map of the LDAP Technical Specification.

RFC-4511 Lightweight Directory Access Protocol (LDAP): The Protocol

http://www.ietf.org/rfc/rfc4511.txt

This document describes the protocol elements, along with their semantics and encodings, of the Lightweight Directory Access Protocol (LDAP). LDAP provides access to distributed directory services that act in accordance with X.500 data and service models. These protocol elements are based on those described in the X.500 Directory Access Protocol (DAP).

RFC-4512 Lightweight Directory Access Protocol (LDAP): Directory Information Models

http://www.ietf.org/rfc/rfc4512.txt

The Lightweight Directory Access Protocol (LDAP) is an Internet protocol for accessing distributed directory services that act in accordance with X.500 data and service models. This document describes the X.500 Directory Information Models, as used in LDAP.

RFC-4513 Lightweight Directory Access Protocol (LDAP): Authentication Methods and Security Mechanisms

http://www.ietf.org/rfc/rfc4513.txt

This document describes authentication methods and security mechanisms of the Lightweight Directory Access Protocol (LDAP). This document details establishment of Transport Layer Security (TLS) using the StartTLS operation.

This document details the simple Bind authentication method including anonymous, unauthenticated, and name/password mechanisms and the Simple Authentication and Security Layer (SASL) Bind authentication method including the EXTERNAL mechanism.

This document discusses various authentication and authorization states through which a session to an LDAP server may pass and the actions that trigger these state changes.

RFC-4514 Lightweight Directory Access Protocol (LDAP): String Representation of Distinguished Names

http://www.ietf.org/rfc/rfc4514.txt

The X.500 Directory uses distinguished names (DNs) as primary keys to entries in the directory. This document defines the string representation used in the Lightweight Directory Access Protocol (LDAP) to transfer distinguished names. The string representation is designed to give a clean representation of commonly used distinguished names, while being able to represent any distinguished name.

RFC-4515 Lightweight Directory Access Protocol (LDAP): String Representation of Search Filters

http://www.ietf.org/rfc/rfc4515.txt

Lightweight Directory Access Protocol (LDAP) search filters are transmitted in the LDAP protocol using a binary representation that is appropriate for use on the network. This document defines a human-readable string representation of LDAP search filters that is appropriate for use in LDAP URLs (RFC 4516) and in other applications.

RFC-4516 Lightweight Directory Access Protocol (LDAP): Uniform Resource Locator

http://www.ietf.org/rfc/rfc4516.txt

This document describes a format for a Lightweight Directory Access Protocol (LDAP) Uniform Resource Locator (URL). An LDAP URL describes an LDAP search operation that is used to retrieve information from an LDAP directory, or, in the context of an LDAP referral or reference, an LDAP URL describes a service where an LDAP operation may be progressed.

RFC-4517 Lightweight Directory Access Protocol (LDAP): Syntaxes and Matching Rules

http://www.ietf.org/rfc/rfc4517.txt

Each attribute stored in a Lightweight Directory Access Protocol (LDAP) directory, whose values may be transferred in the LDAP protocol, has a defined syntax that constrains the structure and format of its values. The comparison semantics for values of a syntax are not part of the syntax definition but are instead provided through separately defined matching rules. Matching rules specify an argument, an assertion value, which also has a defined syntax. This document defines a base set of syntaxes and matching rules for use in defining attributes for LDAP directories.

RFC-4518 Lightweight Directory Access Protocol (LDAP): Internationalized String Preparation

http://www.ietf.org/rfc/rfc4518.txt

The previous Lightweight Directory Access Protocol (LDAP) technical specifications did not precisely define how character string matching is to be performed. This led to a number of usability and interoperability problems. This document defines string preparation algorithms for character-based matching rules defined for use in LDAP.

RFC-4519 Lightweight Directory Access Protocol (LDAP): Schema for User Applications

http://www.ietf.org/rfc/rfc4519.txt

This document is an integral part of the Lightweight Directory Access Protocol (LDAP) technical specification. It provides a technical specification of attribute types and object classes intended for use by LDAP directory clients for many directory services, such as White Pages. These objects are widely used as a basis for the schema in many LDAP directories. This document does not cover attributes used for the administration of directory servers, nor does it include directory objects defined for specific uses in other documents.

Expired but still interesting Internet Drafts

draft-wahl-ldap-adminaddr -- Administrator Address Attribute

Organizations running multiple directory servers need an ability for administrators to determine who is responsible for a particular server. This is conceptually similar to the 'sysContact' object of SNMP. The administratorsAddress attribute allows a server administrator to provide the contact information of the responsible party for an LDAP server. This can be used by management clients which are, for example, checking the state of a replication or referral topology, to provide a way for the user of the management client to send email to manager of a particular server.

draft-zeilenga-ldap-noop -- The LDAP No-Op Control

This document defines the Lightweight Directory Access Protocol (LDAP) No-Op control which can be used to disable the normal effect of an operation. The control can be used to discover how a server might react to a particular update request without updating the directory.

draft-legg-ldap-transfer -- Lightweight Directory Access Protocol (LDAP): Transfer Encoding Options

Each attribute stored in a Lightweight Directory Access Protocol (LDAP) directory has a defined syntax (i.e., data type). A syntax definition specifies how attribute values conforming to the syntax are normally represented when transferred in LDAP operations. This representation is referred to as the LDAP-specific encoding to distinguish it from other methods of encoding attribute values. This document introduces a new category of attribute options, called transfer encoding options, that can be used to specify that the associated attribute values are encoded according to one of these other methods.

draft-furuseth-ldap-untypedobject -- Structural object class 'namedObject' for LDAP/X.500

This document defines an 'namedObject' structural object class for the Lightweight Directory Access Protocol (LDAP) and X.500. This is useful for entries with no natural choice of structural object class, e.g. if an entry must exist even though its contents are uninteresting.

draft-wahl-ldap-p3p -- P3P Policy Attributes for LDAP

This document defines attributes that can be retrieved via Lightweight Directory Access Protocol version 3 (LDAP) requests, which contain URIs pointing to the privacy policy documents. These documents describe the privacy policy concerning access to a directory server, and the privacy policies that apply to the contents of the directory (a subtree of entries).

draft-chu-ldap-xordered -- Ordered Entries and Values in LDAP

As LDAP is used more extensively for managing various kinds of data, one often encounters a need to preserve both the ordering and the content of data, despite the inherently unordered structure of entries and attribute values in the directory. This document describes a scheme to attach ordering information to attributes in a directory so that the ordering may be preserved and propagated to other LDAP applications.

draft-chu-ldap-logschema -- A Schema for Logging the LDAP Protocol

In order to facilitate remote administration and auditing of LDAP server operation, it is desirable to provide the server's operational logs themselves as a searchable LDAP directory. These logs may also be used as a persistent change log to support various replication mechanisms. This document defines a schema that may be used to represent all of the requests that have been processed by an LDAP server. It may be used by various applications for auditing, flight recorder, replication, and other purposes.

draft-zeilenga-ldap-relax -- The LDAP Relax Rules Control

This document defines the Lightweight Directory Access Protocol (LDAP) Relax Rules Control which allows a directory user agent (a client) to request the directory service temporarily relax enforcement of various data and service model rules.

draft-gpaterno-dhcp-ldap -- DHCP Option for LDAP Directory Services discovery

This document defines a new DHCP option for delivering configuration information for LDAP services. Through this option, the client receives an LDAP URL [8] of the closest available LDAP server/replica that can be used to authenticate users or look up any useful data.

draft-schleiff-ldap-xri -- LDAP Schema for eXtensible Resource Identifier (XRI)

This document describes Attribute Types and an Object Class for use in representing XRI (eXtensible Resource Identifier) values in LDAP (Lightweight Directory Access Protocol) and X.500 directory services.

draft-wahl-ldap-session -- LDAP Session Tracking Control

Many network devices, application servers, and middleware components of a enterprise software infrastructure generate some form of session tracking identifiers, which are useful when analyzing activity and accounting logs to group activity relating to a particular session. This document discusses how Lightweight Directory Access Protocol version 3 (LDAP) clients can include session tracking identifiers with their LDAP requests. This information is provided through controls in the requests the clients send to LDAP servers. The LDAP server receiving these controls can include the session tracking identifiers the log messages it writes, enabling LDAP requests in the LDAP server's logs to be correlated with activity in logs of other components in the infrastructure. The control also enables session tracking information to be generated by LDAP servers and returned to clients and other servers. Three formats of session tracking identifiers are defined in this document.

draft-wahl-ldap-subtree-source -- LDAP Subtree Data Source URI Attribute

This document defines an attribute that enables administrative clients using the Lightweight Directory Access Protocol (LDAP) to determine the source of directory entries.

draft-ietf-ldapext-psearch -- Persistent Search: A Simple LDAP Change Notification Mechanism

This document defines two controls that extend the LDAPv3 search operation to provide a simple mechanism by which an LDAP client can receive notification of changes that occur in an LDAP server. The mechanism is designed to be very flexible yet easy for clients and servers to implement.

draft-ietf-ldapext-ldapv3-vlv -- LDAP Extensions for Scrolling View Browsing of Search Results

This document describes a Virtual List View control extension for the LDAP Search operation. This control is designed to allow the "virtual list box" feature, common in existing commercial e-mail address book applications, to be supported efficiently by LDAP servers. LDAP servers' inability to support this client feature is a significant impediment to LDAP replacing proprietary protocols in commercial e-mail systems.

The control allows a client to specify that the server return, for a given LDAP search with associated sort keys, a contiguous subset of the search result set. This subset is specified in terms of offsets into the ordered list, or in terms of a greater than or equal comparison value.

Where to find the latest information

Latest information on the RFCs and drafts around LDAP can be found at IETF's datatracker <https://datatracker.ietf.org>.

Releases

13 releases since Debian 3.0 (Woody); the text changed 9 times.

  1. 3.0
  2. 3.1
  3. 4.0
  4. 5.0
  5. 6.0
  6. 7
  7. 8
  8. 9–10
  9. 11–13
  10. Arch

From perl-ldap 0.68-8 in Arch Linux 2026-11-01. Parsed by carta from the page's man source.