Net::DNS::Mailbox3pm
Dns mailbox representation
Usage
use Net::DNS::Mailbox;$mailbox = Net::DNS::Mailbox->new('[email protected]');$address = $mailbox->address;
Overview
The Net::DNS::Mailbox module implements a subclass of DNS domain name objects representing the DNS coded form of RFC822 mailbox address.
The Net::DNS::Mailbox1035 and Net::DNS::Mailbox2535 packages implement mailbox representation subtypes which provide the name compression and canonicalisation specified by RFC1035 and RFC2535. These are necessary to meet the backward compatibility requirements introduced by RFC3597.
Methods
new
$mailbox = Net::DNS::Mailbox->new('John Doe <[email protected]>');$mailbox = Net::DNS::Mailbox->new('[email protected]');$mailbox = Net::DNS::Mailbox->new('john\.doe.example.com');
Creates a mailbox object representing the RFC822 mail address specified by the character string argument. An encoded domain name is also accepted for backward compatibility with Net::DNS 0.68 and earlier.
The argument string consists of printable characters from the 7-bit ASCII repertoire.
address
$address = $mailbox->address;
Returns a character string containing the RFC822 mailbox address corresponding to the encoded domain name representation described in RFC1035 section 8.
Releases
7 releases since Debian 8 (Jessie); the text changed 6 times.