Net::DNS::DomainName3pm
Dns name representation
Usage
use Net::DNS::DomainName;$object = Net::DNS::DomainName->new('example.com');$name = $object->name;$data = $object->encode;( $object, $next ) = Net::DNS::DomainName->decode( \$data, $offset );
Overview
The Net::DNS::DomainName module implements the concrete representation of DNS domain names used within DNS packets.
Net::DNS::DomainName defines methods for encoding and decoding wire format octet strings. All other behaviour is inherited from Net::DNS::Domain.
The Net::DNS::DomainName1035 and Net::DNS::DomainName2535 packages implement disjoint domain name subtypes which provide the name compression and canonicalisation specified by RFC1035 and RFC2535. These are necessary to meet the backward compatibility requirements introduced by RFC3597.
Methods
new
$object = Net::DNS::DomainName->new('example.com');
Creates a domain name object which identifies the domain specified by the character string argument.
decode
$object = Net::DNS::DomainName->decode( \$buffer, $offset, $hash );( $object, $next ) = Net::DNS::DomainName->decode( \$buffer, $offset, $hash );
Creates a domain name object which represents the DNS domain name identified by the wire-format data at the indicated offset within the data buffer.
The argument list consists of a reference to a scalar containing the wire-format data and specified offset. The optional reference to a hash table provides improved efficiency of decoding compressed names by exploiting already cached compression pointers.
The returned offset value indicates the start of the next item in the data buffer.
encode
$data = $object->encode;
Returns the wire-format representation of the domain name suitable for inclusion in a DNS packet buffer.
canonical
$data = $object->canonical;
Returns the canonical wire-format representation of the domain name as defined in RFC2535(8.1).
Net::DNS::DomainName1035
Net::DNS::DomainName1035 implements a subclass of domain name objects which are to be encoded using the compressed wire format defined in RFC1035.
$data = $object->encode( $offset, $hash );
The arguments are the offset within the packet data where the domain name is to be stored and a reference to a hash table used to index compressed names within the packet.
Note that RFC3597 implies that only the RR types defined in RFC1035(3.3) are eligible for compression of domain names occuring in RDATA.
If the hash reference is undefined, encode() returns the lower case uncompressed canonical representation defined in RFC2535(8.1).
Net::DNS::DomainName2535
Net::DNS::DomainName2535 implements a subclass of domain name objects which are to be encoded using uncompressed wire format.
$data = $object->encode( $offset, $hash );
The arguments are the offset within the packet data where the domain name is to be stored and a reference to a hash table used to index names already encoded within the packet.
If the hash reference is undefined, encode() returns the lower case uncompressed canonical representation defined in RFC2535(8.1).
Note that RFC3597, and latterly RFC4034, specifies that the lower case canonical form is to be used for RR types defined prior to RFC3597.
Releases
7 releases since Debian 8 (Jessie); the text changed 6 times.